Solve Ubuntu MinerGate problem

From time to time when you have a new VM (Virtual Machine) with Ubuntu as operating system and want to install the miners. So..you got this little error:

root@aa:# dpkg -i deb-cli
dpkg: warning: downgrading minergate from 6.9-gcc5 to 6.9-gcc4
(Reading database ... 161788 files and directories currently installed.)
Preparing to unpack deb ...
Unpacking minergate (6.9-gcc4) over (6.9-gcc5) ...
dpkg: dependency problems prevent configuration of minergate:
 minergate depends on libx11-xcb1; however:
  Package libx11-xcb1 is not installed.
 minergate depends on libxcb-keysyms1; however:
  Package libxcb-keysyms1 is not installed.
 minergate depends on libxcb-image0; however:
  Package libxcb-image0 is not installed.
 minergate depends on libxcb-icccm4; however:
  Package libxcb-icccm4 is not installed.
 minergate depends on libxcb-sync1; however:
  Package libxcb-sync1 is not installed.
 minergate depends on libxcb-render-util0; however:
  Package libxcb-render-util0 is not installed.

dpkg: error processing package minergate (--install):
 dependency problems - leaving unconfigured
Processing triggers for mime-support (3.54ubuntu1.1) ...
Errors were encountered while processing:
 minergate

This errors are telling us that we need to install the following packages:

You can either install every package manually using this command line:

apt-get install libx11-xcb1

But attention! You may need to install another packages for each package installed, so you can install all of it very fast by using this command line:

apt-get -f install

What this does? Well apt-get is a simple command line interface for downloading and installing packages. The most frequently used commands are update and install.

apt-get -f stands for - Attempt to correct a system with broken dependencies in place. So..it will call our dependencies,  in our case:

apt-get -f install stands for Attempt to correct a system with broken dependencies in place and Install new packages (pkg is libc6 not libc6.deb).

Run this command line to install needed packages, then run the default install:

dpkg -i deb-cli

After that you will get the minergate access.

minergate-cli -user email_address -coin 1 &